System Requirements

We have made every effort to make this website compatible with as many browsers as possible, though due to the different nature of certain older versions we recommend you use latest version of the browser you are currently using.

Browsers

At the time of release, this website is tested on Google Chrome, Firefox v12, Internet Explorer 9 and Safari.